QUICKPRINT UPGRADE

WHAT'S NEW IN QP 5.7

 

Quickprint 5.7 works with all high-end design applications and operating systems that you love.
+ Adobe Creative Cloud 2019
+ Mac OS X Mojave
+ Windows 10 / 64 bit

 

REQUIREMENTS


+ Mac OS X 10.8 to 10.14.x
+ Windows 7 & above
+ Minimum 2Gb RAM (8Gb recommended)
+ 2Gb of hard drive space

 

COMPATIBILITY

 

+ Adobe Creative Cloud CC9.0 to CC14.0.1(2019)
+ Quark 9 & 10
+ Internet connectivity (documentation here)

 

Please DO NOT install Quickprint 5.7 if you use ADOBE CREATIVE SUITE (CS1 to CS6).

WORLD CLASS TECHNICAL SUPPORT

 

Adstream provides you with world-class products and a team of Print industry experts to help you get the most out of your production workflow.

 

Contact us today, we'd love to hear from you.

 

Asia

E: printsupport.asia@adstream.com

T: +60 3 2240 2288

  • LinkedIn Social Icon
  • Facebook Social Icon
  • Twitter Social Icon
FOLLOW US :